Spiga

Creative Zen V Plus con Gnomad2 (ACTUALIZADO)

NOTA: Para instalar GNOMAD2 y poder conectar Creative Zen V Plus en Feisty Fawn, lee el siguiente articulo:

Creative Zen VPlus en Feisty Fawn

-------------------------------------

Después de algún tiempo buscando una alternativa al articulo que ya hice en este blog sobre como transferir archivos de mi Creative Zen V Plus al pc (y viceversa), he encontrado una alternativa mucho mas estable y cómoda que la opción anterior con Amarok. Esta vez configuraremos Ubuntu con Gnomad. Para ello solo tenemos que seguir los siguientes pasos:


.- Descargar lo necesario:
Lo primero que nos hace falta es descargar: gnomad2, libmtp y libnjb. Lo podemos hacer de dos maneras:

1.- Descargando los tres archivos juntos desde "aquí" (Via julay.it)

2.- Descargando los desde las webs oficiales de los proyectos:
Nota: Yo he optado por usar la primera opción y descargar todos los archivos necesarios juntos, pero si se descargan cada uno desde su página web también es valido para la instalación.


.- Pre-instalación:
Lo primero que tenemos que hacer antes de nada es descargar lo esencial para la instalación. Para ello abrimos la consola y ponemos:

# sudo apt-get install build-essential libxml-perl libid3tag0-dev libusb-dev libgtk2.0-dev checkinstall

Una vez hecho esto pasamos a descomprimir en el escritorio el archivo descargado anteriormente (gnomad2-libmtp-libnjb.zip). Una vez descomprimido, otra vez desde consola, ponemos lo siguiente:

# cd ~/Desktop
# tar -zxvf libmtp-0.0.19.tar.gz
# tar -zxvf libnjb-2.2.5.tar.gz
# tar -zxvf gnomad2-2.8.8.tar.gz


.- Instalación de libmtp:
Tenemos que poner en la consola la siguiente cadena de comandos:

# cd libmtp-0.0.19
# ./configure –prefix=/usr
# sudo make
# sudo checkinstall

Una vez hecho esto, tenemos que copiar el archivo libmtp.rules a /etc/udev/rules.d/:

# sudo cp libmtp.rules /etc/udev/rules.d/


.- Instalación de libnjb:
Ahora llega el momento de instalar libnjb. Desde consola:

# cd ..
# cd libnjb-2.2.5
# ./configure –prefix=/usr –enable-hotplugging
# sudo make
# sudo checkinstall

Nota: Aquí me encontré con un problema y es que "-prefix=/usr" y "-enable-hotplugging" me daban error al configurarlos. Si no te encuentras con ninguno de estos errores, no pongas los siguientes comandos. Mi solución fue poner lo siguiente:

# ./configure prefix=/usr
# sudo make
# sudo checkinstall

Ahora llega el momento de copiar y editar nomad.rules:

# sudo cp nomad.rules /etc/udev/rules.d/
# sudo gedit /etc/udev/rules.d/nomad.rules

Una vez abierto el archivo nomad.rules con gedit, donde salen los diferentes códigos de los productos, ponemos:

# Creative Zen V Plus
SYSFS{idVendor}==”041e”, SYSFS{idProduct}==”4152″, GROUP=”plugdev”, MODE=”0660″

Una vez editado el archivo, grabamos y pasamos a instalar Gnomad2.


.- Instalación de Gnomad2:
Para instalar Gnomad2 en nuestro sistema:

# cd ..
# cd gnomad2-2.8.8
# ./configure
# sudo make
# sudo checkinstall

.- Por ultimo:
Ponemos en la consola:

# sudo /etc/init.d/udev restart

Una vez hecho esto, tenemos que ejecutar siempre Gnomad2 como root. Para ello creamos un lanzador y en "comando" ponemos "gksudo gnomad2" o lo ejecutamos desde consola con:

# sudo gnomad2

Basado en: Linux (Ubuntu) e Creative Zen V Plus

---------------



Nota final:
Me he encontrado con un par de problemas después de seguir este manual.
  1. Hay veces que no se por que razón al leer ciertos archivos para pasarlos al reproductor de MP3, Gnomad2 se cierra.
  2. Al actualizar Gnomad2, deja de reconocer el reproductor Creative.
Espero dar con la respuesta pronto.


ACTUALIZADO: Gracias a un comentario se ha conseguido simplificar más aun la instalación de GNOMAD2. Seguir los siguientes pasos:
  1. Es preferible descargar los paquetes por separado, pues de este modo ganamos dos cosas: la primera, es que ya no hay que descomprimirlos (los principiantes nos asustamos con cosas tan sencillas como descomprimir un archivo...jeje). En segundo lugar, podemos bajarnos los paquetes mas actualizados. En mi caso he bajado libmtp 0.1.5, gnomed2 2.8.13, y libnjb 2.2.5.
  2. AL descargar los paquetes mas acutalizados, los pasos se simplifican puesto que ya no hay que modificar el nomad.rules (podemos saltarnos este paso, pues el zenV ya está descrito)
  3. Instalar las librerías y el gnomad2 me dio infinidad de problemas con el comando checkinstall, así que probé a las bravas con ./configure, luego sudo make, y finalmente sudo make install y chaaaaaaaaaaaan instalado.
Finalmente arranco gnomad desde la consola y SOY FELIZ.
Si tu eres feliz, yo soy feliz hehe
Saludos.

11 comentarios:

  Koki

15 de abril de 2007, 8:26

Con Kubuntu 7.04 me funcionó simplemente instalando con Aptitude libtmp, gnomad2 y libnjb. No fue necesario compilar paquetes :)

Tal vez mañana pruebe en Amarok compilándolo.

Saludos

  NeoDaVe

15 de abril de 2007, 8:37

Perfecto pues :D

Lo que pasa es que ahora tengo instalado la 6.10 64-bit de ubuntu y no probé a hacerlo funcionar con la 7.04. Pero gracias por la info.

Saludos!

  Albert

9 de mayo de 2007, 0:50

"Con Kubuntu 7.04 me funcionó simplemente instalando con Aptitude libtmp, gnomad2 y libnjb. No fue necesario compilar paquetes :)

Tal vez mañana pruebe en Amarok compilándolo.

Saludos
"

Para KDE tienes Kzenexplorer.

Saludos.

  NeoDaVe

10 de mayo de 2007, 2:26

Kzenexplorer... que bueno :D Gracias albert!

  Anónimo

2 de agosto de 2007, 18:20

Estoy teniendo infinidad de problemas para que mi ZEn Vplus se entienda con Ubuntu Feisty. Lo intente con el how to con amarok y no lo conseguí pese a mis múltiples intentonas. Ahora con Gnomad2. NO CONSIGO INSTALAR EL GNOMAD con los comandos que me decís, y me da el siguiente error cuando pongo el sudo
make "sudo make
make: *** No se especificó ningún objetivo y no se encontró ningún makefile. Alto."

Estoy dedicando muchas horas tratando de conseguir la comunicación con el Zen pero no lo consigo. Podeis ayudarme?

  NeoDaVe

2 de agosto de 2007, 18:23

Dame tiempo y te intento solucionar el problema :D

  NeoDaVe

2 de agosto de 2007, 18:59

He tardado mucho?

http://belinuxmyfriend.blogspot.com/2007/08/creative-zen-vplus-en-feisty-fawn-con.html

Espero que esto te resuelva el problema, anónimo ;)

  Anónimo

2 de agosto de 2007, 19:30

POR FIN!!! Lo he conseguido. Soy el anónimo de la anterior consulta. Tengo algunas sugerencias para mejorar el how-to:
1.- Es preferible descargar los paquetes por separado, pues de este modo ganamos dos cosas: la primera, es que ya no hay que descomprimirlos (los principiantes nos asustamos con cosas tan sencillas como descomprimir un archivo...jeje). En segundo lugar, podemos bajarnos los paquetes mas actualizados. En mi caso he bajado libmtp 0.1.5, gnomed2 2.8.13, y libnjb 2.2.5.
2.- AL descargar los paquetes mas acutalizados, los pasos se simplifican puesto que ya no hay que modificar el nomad.rules (podemos saltarnos este paso, pues el zenV ya está descrito)
3.- Instalar las librerías y el gnomad2 me dio infinidad de problemas con el comando checkinstall, así que probé a las bravas con ./configure, luego sudo make, y finalmente sudo make install y chaaaaaaaaaaaan instalado.

Finalmente arranco gnomad desde la consola y SOY FELIZ.

GRACIAS. Espero haber aportado mi granito de arena. pacomormar@gmail.com

  NeoDaVe

2 de agosto de 2007, 19:38

Veo que no has dejado tiempo ni a que responda hehe
Gracias por el aporte :)

  Anónimo

31 de diciembre de 2007, 17:57

Acabo de comprarme un zen creative v plus y tengo un problema con los videos. Se supone que lee archivos .avi, pero no me los reconoce. Los intento convertir con el programa del propio mp4, pero me dice que hay un error y no puede hacerlo. Me podeis ayudar? gracias por anticipado

  Daniel

28 de julio de 2009, 4:30

Hola! Gracias por la información. Estoy usando Fedora, y algunas cosas no resultan, tiene alguna sugerencia?